Skip to main content
← All vulnerabilities
CVE-2025-24860GHSA-3CJF-FWCQ-XH22BIT-CASSANDRA-2025-24860

Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.16, 4.1.8, 5.0.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Cassandra

    From 4.0.0 · through 4.0.15; From 4.1.0 · through 4.1.7; From 5.0.0 · through 5.0.2

  • org.apache.cassandra:cassandra-allMaven

    From 4.0-alpha1 · fixed in 4.0.16

  • org.apache.cassandra:cassandra-allMaven

    From 4.1-alpha1 · fixed in 4.1.8

  • org.apache.cassandra:cassandra-allMaven

    From 5.0-alpha1 · fixed in 5.0.3

References 1

lists.apache.org