Skip to main content
← All vulnerabilities
CVE-2025-24813GHSA-83QJ-6FR2-VHQGBIT-TOMCAT-2025-24813

Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

Published
Last modified
published
Listed in CISA KEV
Fix
Fixed in 11.0.3, 10.1.35, 9.0.99
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Tomcat versions 9, 10.1, and 11 (plus the end-of-life 8.5 line) are affected when the default servlet has write enabled and partial PUT support is on, which lets remote attackers reach security-sensitive files through a crafted filename. The impact can include viewing sensitive files, tampering with file contents, or remote code execution in specific configurations.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) • support for partial PUT (enabled by default) • a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: • writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.2; From 10.1.0-M1 · through 10.1.34; From 9.0.0.M1 · through 9.0.98; From 8.5.0 · through 8.5.100

  • org.apache.tomcat:tomcat-catalinaMaven

    From 11.0.0-M1 · fixed in 11.0.3

  • org.apache.tomcat:tomcat-catalinaMaven

    From 10.1.0-M1 · fixed in 10.1.35

  • org.apache.tomcat:tomcat-catalinaMaven

    From 9.0.0.M1 · fixed in 9.0.99

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.0-M1 · fixed in 11.0.3

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.0-M1 · fixed in 10.1.35

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.0.M1 · fixed in 9.0.99

  • org.apache.tomcat:tomcat-catalinaMaven

    From 8.5.0 · through 8.5.100

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 8.5.0 · through 8.5.100

References 1

lists.apache.org