Skip to main content
← All vulnerabilities
CVE-2025-24434GHSA-FPPQ-F2M6-XV5C

Adobe Commerce | Incorrect Authorization (CWE-863)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.8-beta2, 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Incorrect Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Adobe Adobe Commerce

    through 2.4.8-beta1

  • magento/community-editionPackagist

    From 2.4.8-beta1 · fixed in 2.4.8-beta2

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p9

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p11

  • magento/community-editionPackagist

    fixed in 2.4.4-p12

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com