Skip to main content
← All vulnerabilities
CVE-2025-24424GHSA-539V-W87W-W62C

Adobe Commerce | Improper Access Control (CWE-284)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain unauthorized read access. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.8-beta1

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p9

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p11

  • magento/community-editionPackagist

    fixed in 2.4.4-p12

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    2.4.8-beta1

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com