Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Adobe Adobe Commerce
through 2.4.8-beta1
- magento/community-editionPackagist
From 2.4.7-beta1 · fixed in 2.4.7-p4
- magento/community-editionPackagist
From 2.4.6-p1 · fixed in 2.4.6-p9
- magento/community-editionPackagist
From 2.4.5-p1 · fixed in 2.4.5-p11
- magento/community-editionPackagist
fixed in 2.4.4-p12
- magento/community-editionPackagist
2.4.7
- magento/community-editionPackagist
2.4.6
- magento/community-editionPackagist
2.4.5
- magento/community-editionPackagist
2.4.4
- magento/community-editionPackagist
2.4.8-beta1
- magento/project-community-editionPackagist
through 2.0.2