Skip to main content
← All vulnerabilities
CVE-2025-24412GHSA-M4RG-MPP2-97PX

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.8-beta1

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p9

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p11

  • magento/community-editionPackagist

    fixed in 2.4.4-p12

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    2.4.8-beta1

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com