Skip to main content
← All vulnerabilities
CVE-2025-23388GHSA-XR9Q-H9C7-XW8QGO-2025-3491

Unauthenticated stack overflow in /v3-public/authproviders API

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.8.13, 2.9.7, 2.10.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • github.com/rancher/rancher

    From 2.8.0 · fixed in 2.8.13; From 2.9.0 · fixed in 2.9.7; From 2.10.0 · fixed in 2.10.3

  • github.com/rancher/rancherGo

    From 2.8.0 · fixed in 2.8.13

  • github.com/rancher/rancherGo

    From 2.9.0 · fixed in 2.9.7

  • github.com/rancher/rancherGo

    From 2.10.0 · fixed in 2.10.3

  • github.com/rancher/rancherGo

    All versions

References 2

bugzilla.suse.com

GitHub · rancher/rancher