Skip to main content
← All vulnerabilities
CVE-2025-23210GHSA-R57H-547H-W24F

Bypass XSS sanitizer using the javascript protocol and special characters in phpoffice/phpspreadsheet

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.0, 2.3.7, 2.1.8, 1.29.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

phpoffice/phpspreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions have been found to have a Bypass of the Cross-site Scripting (XSS) sanitizer using the javascript protocol and special characters. This issue has been addressed in versions 3.9.0, 2.3.7, 2.1.8, and 1.29.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • PHPOffice PhpSpreadsheet

    From 3.0.0 · fixed in 3.9.0; From 2.2.0 · fixed in 2.3.7; From 2.0.0 · fixed in 2.1.8; fixed in 1.29.9

  • phpoffice/phpspreadsheetPackagist

    From 3.0.0 · fixed in 3.9.0

  • phpoffice/phpspreadsheetPackagist

    fixed in 1.29.9

  • phpoffice/phpspreadsheetPackagist

    From 2.2.0 · fixed in 2.3.7

  • phpoffice/phpspreadsheetPackagist

    From 2.0.0 · fixed in 2.1.8

  • phpoffice/phpexcelPackagist

    through 1.8.2

References 2

GitHub · PHPOffice/PhpSpreadsheet