Skip to main content
← All vulnerabilities
CVE-2025-23078

XSS in BreadCrumbs2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.39.11, 1.41.5, 1.42.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - Breadcrumbs2 extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - Breadcrumbs2 extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.5, from 1.42.X before 1.42.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Wikimedia Foundation Mediawiki - Breadcrumbs2 extension

    From 1.39.x · fixed in 1.39.11; From 1.41.x · fixed in 1.41.5; From 1.42.x · fixed in 1.42.4

References 2

phabricator.wikimedia.org

gerrit.wikimedia.org