CVE-2025-23061GHSA-VG7J-7CWX-8WGWBIT-MONGOOSE-2025-23061
Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.13.6, 7.8.4, 8.9.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub, 1 Nuclei template
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection. NOTE: this issue exists because of an incomplete fix for CVE-2024-53900.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- mongoosejs Mongoose
From 6.0.0 · fixed in 6.13.6; From 7.0.0 · fixed in 7.8.4; From 8.0.0 · fixed in 8.9.5
- mongoosenpm
From 8.0.0-rc0 · fixed in 8.9.5
- mongoosenpm
From 7.0.0-rc0 · fixed in 7.8.4
- mongoosenpm
fixed in 6.13.6