Skip to main content
← All vulnerabilities
CVE-2025-23015GHSA-WMCC-9VCH-JMX4BIT-CASSANDRA-2025-23015

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.3, 4.1.8, 4.0.16, 3.11.18, 3.0.31
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Cassandra

    From 3.0.0 · through 3.0.30; From 3.1.0 · through 3.11.17; From 4.0.0 · through 4.0.15; From 4.1.0 · through 4.1.7; From 5.0.0 · through 5.0.2

  • org.apache.cassandra:cassandra-allMaven

    From 5.0-alpha1 · fixed in 5.0.3

  • org.apache.cassandra:cassandra-allMaven

    From 4.1-alpha1 · fixed in 4.1.8

  • org.apache.cassandra:cassandra-allMaven

    From 4.0-alpha1 · fixed in 4.0.16

  • org.apache.cassandra:cassandra-allMaven

    From 3.1 · fixed in 3.11.18

  • org.apache.cassandra:cassandra-allMaven

    fixed in 3.0.31

References 1

lists.apache.org