CVE-2025-22131GHSA-79XX-VF93-P7CX
Cross-Site Scripting (XSS) vulnerability in generateNavigation() function
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.8.0, 2.3.6, 2.1.7, 1.29.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Cross-Site Scripting (XSS) vulnerability in the code which translates the XLSX file into a HTML representation and displays it in the response.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- PHPOffice PhpSpreadsheet
From 3.0.0 · fixed in 3.8.0; From 2.2.0 · fixed in 2.3.6; From 2.0.0 · fixed in 2.1.7; fixed in 1.29.8
- phpoffice/phpspreadsheetPackagist
From 3.0.0 · fixed in 3.8.0
- phpoffice/phpspreadsheetPackagist
fixed in 1.29.8
- phpoffice/phpspreadsheetPackagist
From 2.0.0 · fixed in 2.1.7
- phpoffice/phpspreadsheetPackagist
From 2.2.0 · fixed in 2.3.6
- phpoffice/phpexcelPackagist
through 1.8.2