CVE-2025-21614GO-2025-3367GHSA-R9PX-M959-CXF4
go-git clients vulnerable to DoS via maliciously crafted Git server replies
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.13.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- go-git go-git
From 4.0.0 · fixed in 5.13.0
- github.com/go-git/go-git/v4Go
From 4.0.0
- github.com/go-git/go-git/v5Go
fixed in 5.13.0
- gopkg.in/src-d/go-git.v4Go
From 4.0.0
- gopkg.in/src-d/go-git.v4Go
From 4.0.0 · through 4.13.1
- github.com/go-git/go-gitGo
From 4.0.0 · through 4.13.1