Skip to main content
← All vulnerabilities
CVE-2025-20086GHSA-5M7J-6GC4-FF5GGO-2025-3392

Insufficient Input Validation on Post Props

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5, and 4 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 9.11.0 · through 9.11.5; From 10.0.0 · through 10.0.3; From 10.1.0 · through 10.1.3

  • github.com/mattermost/mattermost/server/v8Go

    From 10.2.0 · fixed in 10.2.1

  • github.com/mattermost/mattermost/server/v8Go

    From 10.1.0 · fixed in 10.1.4

  • github.com/mattermost/mattermost/server/v8Go

    From 10.0.0 · fixed in 10.0.4

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0 · fixed in 9.11.6

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20241127161322-25ff7a3779a5

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible · fixed in 9.11.6+incompatible; From 10.0.0+incompatible · fixed in 10.0.4+incompatible; From 10.1.0+incompatible · fixed in 10.1.4+incompatible; From 10.2.0+incompatible · fixed in 10.2.1+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

References 1

mattermost.com