Skip to main content
← All vulnerabilities
CVE-2025-20033GO-2025-3379GHSA-2549-XH72-QRPM

DoS via custom post type for sysconsole plugin readers

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.0.4+incompatible, 10.1.4+incompatible, 10.2.1+incompatible, 8.0.0-20250102081831-64c566a8280b, 9.11.16, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsole_read_plugins permission via creating a post with the custom_pl_notification type and specific props.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 9.11.0 · through 9.11.5; From 10.0.0 · through 10.0.3; From 10.1.0 · through 10.1.3

  • github.com/mattermost/mattermost-serverGo

    From 10.0.0+incompatible · fixed in 10.0.4+incompatible; From 10.1.0+incompatible · fixed in 10.1.4+incompatible; From 10.2.0+incompatible · fixed in 10.2.1+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20250102081831-64c566a8280b

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0 · fixed in 9.11.16

  • github.com/mattermost/mattermost/server/v8Go

    From 10.0.0 · fixed in 10.0.4

  • github.com/mattermost/mattermost/server/v8Go

    From 10.1.0 · fixed in 10.1.4

  • github.com/mattermost/mattermost/server/v8Go

    From 10.2.0 · fixed in 10.2.1

References 1

mattermost.com